AndroidSDK 25.3.1 Unity3D 빌드 실패

android sdk 업데이트 진행시 주의해야할 점이 생겨버렸다.
Tools 25.3.1 이후부터는 Unity3D 에서 빌드가 되지 않는다.

얼마전 늦은저녁에 애써 시간내서 노트북들고 뭐라도 해볼라고 깝쭉거리다가
이 이슈로인해 몇시간을 보내버렸다.

Unity에서 내 뿜던 로그는 대충 이러하다.

Error building Player: CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details.
/Library/Java/JavaVirtualMachines/jdk1.8.0_121.jdk/Contents/Home/bin/java -Xmx2048M -Dcom.android.sdkmanager.toolsdir="$HOME/Library/Android/sdk/tools" -Dfile.encod
ing=UTF8 -jar "/Applications/Unity 5.5.0f3/PlaybackEngines/AndroidPlayer/Tools/sdktools.jar" -

stderr[
Error:Invalid command android
]
stdout[

]
exit code: 64

(Filename: Line: -1)

$ android
The android command is no longer available.
For manual SDK and AVD management, please use Android Studio.
For command-line tools, use tools/bin/sdkmanager and tools/bin/avdmanager

그래서 해결 방법은~

Android SDK Tools 25.2.5 버전을 내려 받아서 복사하라~

http://dl-ssl.google.com/android/repository/tools_r25.2.5-windows.zip
http://dl-ssl.google.com/android/repository/tools_r25.2.5-macosx.zip

Android SDK 설치 폴더 중 Tools 디렉토리를 잠시 다른거로 변경해놓고
위 파일을 다운받아 압축풀어 교체하면 된다.

덧붙임 글 :
5.6.0f3 마찬가지다.
메롱스럽다.